Plataforma ISIS BIREME

De Wiki.bireme.org/pt
Ir para: navegação, pesquisa

Objetivo

Definir processos de testes e validação do pacote CISIS versão 5.7a - 64 bits disponível para plataforma Linux.

NOTA:

  • É necessário que os testes sejam realizados em distribuições Linux 64 bits.
  • O uso dos utilitários permanece inalterado. Não foi acrescentado e nem retirado nenhum comando, parâmetro ou variável.
  • O comportamento dos utilitários não difere entre as versões 32 e 64 bits.
  • Versão para Windows ainda não disponível.

Quais são os pacotes disponíveis

  • Cisis utilitários 10/30
  • Cisis utilitários 16/60
  • Cisis utilitários LIND
  • Cisis utilitários FFI

Onde baixar os pacotes

Os pacotes pod em ser baixados em: http://trac.reddes.bvsalud.org/projects/cisis/browser/trunk/utl/linux64

Considerações para testes

Os testes a serem realizados nos aplicativos que utilizam os utilitários CISIS devem considerar:

  1. Não há necessidade de submeter o arquivo mestre (M/F) a qualquer tipo de conversão
  2. Os arquivos invertidos (I/F) devem ser regerados.
    • mx <base> fst=@<arquivo.fst> fullinv=<nome_do_arquivo_invertido> [tell=100]

Como identificar qual versão você está utilizando

http://wiki.bireme.org/pt/index.php/Perguntas_mais_frequentes

Como reportar erros

Acessar o formulário http://bit.ly/isis64error para cadastrar erros referentes a versão CISIS 64 bits.]